using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(\S*)({(\S*)})$";
string input = @"{asvjhkhe980vz9ehh}
{asvjhkhe9_80vz9-ehh}
#anchor
https://linktourl.com
/relativepath/subdirectory
http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#
http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#hash
{0001876v9h39h9-1}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}