# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\S*)({(\S*)})$"
test_str = ("{asvjhkhe980vz9ehh}\n"
"{asvjhkhe9_80vz9-ehh}\n"
"#anchor\n"
"https://linktourl.com\n"
"/relativepath/subdirectory\n"
"http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#\n"
"http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#hash\n"
"{0001876v9h39h9-1}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.