$re = '/^(\S*)({(\S*)})$/m';
$str = '{asvjhkhe980vz9ehh}
{asvjhkhe9_80vz9-ehh}
#anchor
https://linktourl.com
/relativepath/subdirectory
http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#
http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#hash
{0001876v9h39h9-1}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);