const regex = /^(\S*)({(\S*)})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\S*)({(\\S*)})$', 'gm')
const str = `{asvjhkhe980vz9ehh}
{asvjhkhe9_80vz9-ehh}
#anchor
https://linktourl.com
/relativepath/subdirectory
http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#
http://localhost:3000/page/Standard%20Page%20Components%20Test%2011%20Carousel#hash
{0001876v9h39h9-1}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}