import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=-).*";
final String string = "47094629 16/06/2023 AS PARTS 10/06/2023 2065.81 -2.00 2063.81\n"
+ "PURCHASE\n\n"
+ "47868528 14/06/2023 AS PARTS 10/06/2023 3626.35 -3.00 3623.35\n"
+ "PURCHASE\n\n"
+ "47264525 14/06/2023 AS PARTS 10/06/2023 308383.39 -262.00 308121.3\n"
+ "PURCHASE 9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}