const regex = /(?<=-).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=-).*', 'gm')
const str = `47094629 16/06/2023 AS PARTS 10/06/2023 2065.81 -2.00 2063.81
PURCHASE
47868528 14/06/2023 AS PARTS 10/06/2023 3626.35 -3.00 3623.35
PURCHASE
47264525 14/06/2023 AS PARTS 10/06/2023 308383.39 -262.00 308121.3
PURCHASE 9`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}