import Foundation
let pattern = #"(?<=-).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
47094629 16/06/2023 AS PARTS 10/06/2023 2065.81 -2.00 2063.81
PURCHASE
47868528 14/06/2023 AS PARTS 10/06/2023 3626.35 -3.00 3623.35
PURCHASE
47264525 14/06/2023 AS PARTS 10/06/2023 308383.39 -262.00 308121.3
PURCHASE 9
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)