$re = '/(?<=-).*/m';
$str = '47094629 16/06/2023 AS PARTS 10/06/2023 2065.81 -2.00 2063.81
PURCHASE
47868528 14/06/2023 AS PARTS 10/06/2023 3626.35 -3.00 3623.35
PURCHASE
47264525 14/06/2023 AS PARTS 10/06/2023 308383.39 -262.00 308121.3
PURCHASE 9';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);