use strict;
my $str = '47094629 16/06/2023 AS PARTS 10/06/2023 2065.81 -2.00 2063.81
PURCHASE
47868528 14/06/2023 AS PARTS 10/06/2023 3626.35 -3.00 3623.35
PURCHASE
47264525 14/06/2023 AS PARTS 10/06/2023 308383.39 -262.00 308121.3
PURCHASE 9';
my $regex = qr/(?<=-).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}