#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\bInvoice Number : )\S+"
Local $sString = "Credit Notes - Original" & @CRLF & _
"" & @CRLF & _
"Invoice Number : 362/867/88540129 Customer PO : 124698753" & @CRLF & _
"Invoice Date : 2019-10-17 Reference A : BONNEVILLE POWER " & @CRLF & _
"Sales Order : UTS003832 ADMINISTRATIO" & @CRLF & _
"Business Partner : BP0042488 Customer Tax : 12-9871234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")