import Foundation
let pattern = #"(?<=\bInvoice Number : )\S+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Credit Notes - Original
Invoice Number : 362/867/88540129 Customer PO : 124698753
Invoice Date : 2019-10-17 Reference A : BONNEVILLE POWER
Sales Order : UTS003832 ADMINISTRATIO
Business Partner : BP0042488 Customer Tax : 12-9871234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)