$re = '/(?<=\bInvoice Number : )\S+/m';
$str = 'Credit Notes - Original
Invoice Number : 362/867/88540129 Customer PO : 124698753
Invoice Date : 2019-10-17 Reference A : BONNEVILLE POWER
Sales Order : UTS003832 ADMINISTRATIO
Business Partner : BP0042488 Customer Tax : 12-9871234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);