import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\bInvoice Number : )\\S+";
final String string = "Credit Notes - Original\n\n"
+ "Invoice Number : 362/867/88540129 Customer PO : 124698753\n"
+ "Invoice Date : 2019-10-17 Reference A : BONNEVILLE POWER \n"
+ "Sales Order : UTS003832 ADMINISTRATIO\n"
+ "Business Partner : BP0042488 Customer Tax : 12-9871234";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}