# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\bInvoice Number : )\S+"
test_str = ("Credit Notes - Original\n\n"
"Invoice Number : 362/867/88540129 Customer PO : 124698753\n"
"Invoice Date : 2019-10-17 Reference A : BONNEVILLE POWER \n"
"Sales Order : UTS003832 ADMINISTRATIO\n"
"Business Partner : BP0042488 Customer Tax : 12-9871234")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.