using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(https?\:\/\/)?(www\.)?(youtube\.com|youtu\.?be)(\/)?(watch\?v=|\?v=)?(.*)$";
string input = @"https://www.youtube.com/watch?v=osz5tVY97dQ
https://youtube.com/watch?v=osz5tVY97dQ
https://youtube.com/osz5tVY97dQ
youtube.com/watch?v=osz5tVY97dQ
https://www.youtu.be/watch?v=osz5tVY97dQ
https://youtu.be/watch?v=osz5tVY97dQ
https://youtu.be/?v=osz5tVY97dQ
https://youtu.be/osz5tVY97dQ
youtu.be/osz5tVY97dQ
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}