use strict;
my $str = 'https://www.youtube.com/watch?v=osz5tVY97dQ
https://youtube.com/watch?v=osz5tVY97dQ
https://youtube.com/osz5tVY97dQ
youtube.com/watch?v=osz5tVY97dQ
https://www.youtu.be/watch?v=osz5tVY97dQ
https://youtu.be/watch?v=osz5tVY97dQ
https://youtu.be/?v=osz5tVY97dQ
https://youtu.be/osz5tVY97dQ
youtu.be/osz5tVY97dQ
';
my $regex = qr/^(https?\:\/\/)?(www\.)?(youtube\.com|youtu\.?be)(\/)?(watch\?v=|\?v=)?(.*)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}