// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(https?\:\/\/)?(www\.)?(youtube\.com|youtu\.?be)(\/)?(watch\?v=|\?v=)?(.*)$").unwrap();
let string = "https://www.youtube.com/watch?v=osz5tVY97dQ
https://youtube.com/watch?v=osz5tVY97dQ
https://youtube.com/osz5tVY97dQ
youtube.com/watch?v=osz5tVY97dQ
https://www.youtu.be/watch?v=osz5tVY97dQ
https://youtu.be/watch?v=osz5tVY97dQ
https://youtu.be/?v=osz5tVY97dQ
https://youtu.be/osz5tVY97dQ
youtu.be/osz5tVY97dQ
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}