package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?\:\/\/)?(www\.)?(youtube\.com|youtu\.?be)(\/)?(watch\?v=|\?v=)?(.*)$`)
var str = `https://www.youtube.com/watch?v=osz5tVY97dQ
https://youtube.com/watch?v=osz5tVY97dQ
https://youtube.com/osz5tVY97dQ
youtube.com/watch?v=osz5tVY97dQ
https://www.youtu.be/watch?v=osz5tVY97dQ
https://youtu.be/watch?v=osz5tVY97dQ
https://youtu.be/?v=osz5tVY97dQ
https://youtu.be/osz5tVY97dQ
youtu.be/osz5tVY97dQ
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}