# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(https?\:\/\/)?(www\.)?(youtube\.com|youtu\.?be)(\/)?(watch\?v=|\?v=)?(.*)$"
test_str = ("https://www.youtube.com/watch?v=osz5tVY97dQ\n"
"https://youtube.com/watch?v=osz5tVY97dQ\n"
"https://youtube.com/osz5tVY97dQ\n"
"youtube.com/watch?v=osz5tVY97dQ\n"
"https://www.youtu.be/watch?v=osz5tVY97dQ\n"
"https://youtu.be/watch?v=osz5tVY97dQ\n"
"https://youtu.be/?v=osz5tVY97dQ\n"
"https://youtu.be/osz5tVY97dQ\n"
"youtu.be/osz5tVY97dQ\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.