#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "import +{ *(?<export>([a-zA-Z0-9]+,?)+) *} +from +"(?<file>(\.{1,2}|([a-zA-Z0-9-_]+))((?=\/)\/[a-zA-Z0-9-_]+)*)"\s*;"
Local $sString = "" & @CRLF & _
"import {readline} from "./includes/typescript_definitions/codingame";" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"console.log("hi"); " & @CRLF & _
"" & @CRLF & _
"readline();"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")