using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"import +{ *(?<export>([a-zA-Z0-9]+,?)+) *} +from +""(?<file>(\.{1,2}|([a-zA-Z0-9-_]+))((?=\/)\/[a-zA-Z0-9-_]+)*)""\s*;";
string input = @"
import {readline} from ""./includes/typescript_definitions/codingame"";
console.log(""hi"");
readline();";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}