const regex = /import +{ *(?<export>([a-zA-Z0-9]+,?)+) *} +from +"(?<file>(\.{1,2}|([a-zA-Z0-9-_]+))((?=\/)\/[a-zA-Z0-9-_]+)*)"\s*;/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('import +{ *(?<export>([a-zA-Z0-9]+,?)+) *} +from +"(?<file>(\\.{1,2}|([a-zA-Z0-9-_]+))((?=\\\/)\\\/[a-zA-Z0-9-_]+)*)"\\s*;', 'g')
const str = `
import {readline} from "./includes/typescript_definitions/codingame";
console.log("hi");
readline();`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}