$re = '/import +{ *(?<export>([a-zA-Z0-9]+,?)+) *} +from +"(?<file>(\.{1,2}|([a-zA-Z0-9-_]+))((?=\/)\/[a-zA-Z0-9-_]+)*)"\s*;/';
$str = '
import {readline} from "./includes/typescript_definitions/codingame";
console.log("hi");
readline();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);