import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "import +\\{ *(?<export>([a-zA-Z0-9]+,?)+) *\\} +from +\"(?<file>(\\.{1,2}|([a-zA-Z0-9-_]+))((?=\\/)\\/[a-zA-Z0-9-_]+)*)\"\\s*;";
final String string = "\n"
+ "import {readline} from \"./includes/typescript_definitions/codingame\";\n\n\n"
+ "console.log(\"hi\"); \n\n"
+ "readline();";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}