#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[A-Z]\$"
Local $sString = "(1) Ceres 2,7653 1 stycznia 1801 G. Piazzi" & @CRLF & _
"(2) Pallas 2,7722 28 marca 1802 H. W. Olbers" & @CRLF & _
"(3) Juno 2,6701 1 września 1804 K. Harding" & @CRLF & _
"(4) Westa 2,3619 29 marca 1807 H. W. Olbers" & @CRLF & _
"(5) Astraea 2,5771 8 grudnia 1845 K. L. Hencke" & @CRLF & _
"(6) Hebe 2,4256 1 lipca 1847 K. L. Hencke" & @CRLF & _
"(7) Iris 2,3856 13 sierpnia 1847 J. R. Hind"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")