import re
regex = re.compile(r"\[A-Z]\$", flags=re.MULTILINE)
test_str = ("(1) Ceres 2,7653 1 stycznia 1801 G. Piazzi\n"
"(2) Pallas 2,7722 28 marca 1802 H. W. Olbers\n"
"(3) Juno 2,6701 1 września 1804 K. Harding\n"
"(4) Westa 2,3619 29 marca 1807 H. W. Olbers\n"
"(5) Astraea 2,5771 8 grudnia 1845 K. L. Hencke\n"
"(6) Hebe 2,4256 1 lipca 1847 K. L. Hencke\n"
"(7) Iris 2,3856 13 sierpnia 1847 J. R. Hind")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")