$re = '/\[A-Z]\$/m';
$str = '(1) Ceres 2,7653 1 stycznia 1801 G. Piazzi
(2) Pallas 2,7722 28 marca 1802 H. W. Olbers
(3) Juno 2,6701 1 wrzeĊnia 1804 K. Harding
(4) Westa 2,3619 29 marca 1807 H. W. Olbers
(5) Astraea 2,5771 8 grudnia 1845 K. L. Hencke
(6) Hebe 2,4256 1 lipca 1847 K. L. Hencke
(7) Iris 2,3856 13 sierpnia 1847 J. R. Hind';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);