const regex = new RegExp('\\[A-Z]\\$', 'gm')
const str = `(1) Ceres 2,7653 1 stycznia 1801 G. Piazzi
(2) Pallas 2,7722 28 marca 1802 H. W. Olbers
(3) Juno 2,6701 1 września 1804 K. Harding
(4) Westa 2,3619 29 marca 1807 H. W. Olbers
(5) Astraea 2,5771 8 grudnia 1845 K. L. Hencke
(6) Hebe 2,4256 1 lipca 1847 K. L. Hencke
(7) Iris 2,3856 13 sierpnia 1847 J. R. Hind`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}