use strict;
my $str = '(1) Ceres 2,7653 1 stycznia 1801 G. Piazzi
(2) Pallas 2,7722 28 marca 1802 H. W. Olbers
(3) Juno 2,6701 1 września 1804 K. Harding
(4) Westa 2,3619 29 marca 1807 H. W. Olbers
(5) Astraea 2,5771 8 grudnia 1845 K. L. Hencke
(6) Hebe 2,4256 1 lipca 1847 K. L. Hencke
(7) Iris 2,3856 13 sierpnia 1847 J. R. Hind';
my $regex = qr/\[A-Z]\$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}