using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^category/page-(?![01]$)(?P<page>[0-9]+)$";
string input = @"category/page-0
category/page-1
category/page-001
category/page-2
category/page-2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}