import re
regex = re.compile(r"^category/page-(?![01]$)(?P<page>[0-9]+)$", flags=re.MULTILINE)
test_str = ("category/page-0\n"
"category/page-1\n"
"category/page-001\n"
"category/page-2\n"
"category/page-2")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")