re = /^category\/page-(?![01]$)(?P<page>[0-9]+)$/m
str = 'category/page-0
category/page-1
category/page-001
category/page-2
category/page-2'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end