use strict;
my $str = '+2345678901_____
+23456789012____
+234567890123___
+2345678901234__
+23456789012345_
+234567890123456';
my $regex = qr/^\+(?=.{15})\d{10,15}_{0,5}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}