re = /^\+(?=.{15})\d{10,15}_{0,5}$/m
str = '+2345678901_____
+23456789012____
+234567890123___
+2345678901234__
+23456789012345_
+234567890123456'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end