#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:cached(?= .* is)|forwarded(?= .* to)|replied(?= .* by)) (.*) (?:is|to|by)"
Local $sString = "cached 1a23a is" & @CRLF & _
"forwarded 2ab34 to" & @CRLF & _
"replied klaskd by" & @CRLF & _
"cached is1a2is3a to" & @CRLF & _
"forwarded to2abto34 by" & @CRLF & _
"replied byklbyaskd is"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")