re = /(?:cached(?= .* is)|forwarded(?= .* to)|replied(?= .* by)) (.*) (?:is|to|by)/
str = 'cached 1a23a is
forwarded 2ab34 to
replied klaskd by
cached is1a2is3a to
forwarded to2abto34 by
replied byklbyaskd is'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end