use strict;
my $str = 'cached 1a23a is
forwarded 2ab34 to
replied klaskd by
cached is1a2is3a to
forwarded to2abto34 by
replied byklbyaskd is';
my $regex = qr/(?:cached(?= .* is)|forwarded(?= .* to)|replied(?= .* by)) (.*) (?:is|to|by)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}