$re = '/(?:cached(?= .* is)|forwarded(?= .* to)|replied(?= .* by)) (.*) (?:is|to|by)/';
$str = 'cached 1a23a is
forwarded 2ab34 to
replied klaskd by
cached is1a2is3a to
forwarded to2abto34 by
replied byklbyaskd is';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);