import Foundation
let pattern = #"(?:cached(?= .* is)|forwarded(?= .* to)|replied(?= .* by)) (.*) (?:is|to|by)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
cached 1a23a is
forwarded 2ab34 to
replied klaskd by
cached is1a2is3a to
forwarded to2abto34 by
replied byklbyaskd is
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)