use strict;
my $str = '10.5.31.15
45.36.87.12
10.0.100.75
192.168.1.168
10.5.4.15
10.5.32.15
10.10.25.36
10.0.100.56
10.5.29.15';
my $regex = qr/(\b10\.5\.(29|31|32)\.15\b|\b10\.0\.100\.75\b)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}