// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\b10\.5\.(29|31|32)\.15\b|\b10\.0\.100\.75\b)").unwrap();
let string = "10.5.31.15
45.36.87.12
10.0.100.75
192.168.1.168
10.5.4.15
10.5.32.15
10.10.25.36
10.0.100.56
10.5.29.15";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}