# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\b10\.5\.(29|31|32)\.15\b|\b10\.0\.100\.75\b)"
test_str = ("10.5.31.15\n"
"45.36.87.12\n"
"10.0.100.75\n"
"192.168.1.168\n"
"10.5.4.15\n"
"10.5.32.15\n"
"10.10.25.36\n"
"10.0.100.56\n"
"10.5.29.15")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.