import Foundation
let pattern = #"(\b10\.5\.(29|31|32)\.15\b|\b10\.0\.100\.75\b)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
10.5.31.15
45.36.87.12
10.0.100.75
192.168.1.168
10.5.4.15
10.5.32.15
10.10.25.36
10.0.100.56
10.5.29.15
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)