#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=prefix: )(<em>(\w*\d*)<\/em>)"
Local $sString = "<em>word1</em> <em>word2</em> <em>word3</em>" & @CRLF & _
"prefix: <em>word4</em> <em>word5</em>" & @CRLF & _
"<em>word6</em> <em>word7</em>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")