re = /(?<=prefix: )(<em>(\w*\d*)<\/em>)/
str = '<em>word1</em> <em>word2</em> <em>word3</em>
prefix: <em>word4</em> <em>word5</em>
<em>word6</em> <em>word7</em>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end