use strict;
my $str = '<em>word1</em> <em>word2</em> <em>word3</em>
prefix: <em>word4</em> <em>word5</em>
<em>word6</em> <em>word7</em>';
my $regex = qr/(?<=prefix: )(<em>(\w*\d*)<\/em>)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}