import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=prefix: )(<em>(\\w*\\d*)<\\/em>)";
final String string = "<em>word1</em> <em>word2</em> <em>word3</em>\n"
+ "prefix: <em>word4</em> <em>word5</em>\n"
+ "<em>word6</em> <em>word7</em>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}