const regex = /(?<=prefix: )(<em>(\w*\d*)<\/em>)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=prefix: )(<em>(\\w*\\d*)<\\\/em>)', 'g')
const str = `<em>word1</em> <em>word2</em> <em>word3</em>
prefix: <em>word4</em> <em>word5</em>
<em>word6</em> <em>word7</em>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}