using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:spirit_animals\s*=\s*\{|(?!^)\G)\s*'\K([^']+)('\s*:\s*'[^']+',?)";
string substitution = @"$1 Smith$2";
string input = @"var cool_spirit_animals = {
'Abel': 'unicorn',
'Bob': 'lion'
};
var spirit_plants = {
'Cain': 'venus fly trap'
};
var stupid_spirit_animals = {
'Dan': 'lamprey'
};
var spirit_vampires = {
'Emily': 'Buffy',
'Fred': 'Dracula'
};";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}