import Foundation
let pattern = #"(?:spirit_animals\s*=\s*\{|(?!^)\G)\s*'\K([^']+)('\s*:\s*'[^']+',?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
var cool_spirit_animals = {
'Abel': 'unicorn',
'Bob': 'lion'
};
var spirit_plants = {
'Cain': 'venus fly trap'
};
var stupid_spirit_animals = {
'Dan': 'lamprey'
};
var spirit_vampires = {
'Emily': 'Buffy',
'Fred': 'Dracula'
};
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 Smith$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)